Instalar el driver nvidia en Ubuntu 9.04


Actualización: si querés instalar driver nvidia ubuntu 9.10 Karmic Koala andá a este post

Siempre luego de la salida de ubuntu 9.04, escribo algun post sobre como arreglar cosas basicas, hace un tiempo era sobre como instalar drivers de video, sonido, red, codecs de audio y de video, ahora lo unico que está causando algún que otro problema es el video, recien lo hice funcionar en mi pc de escritorio en la que tengo una Nvidia gforce 6600 (si, si , ya se, esta mas para un museo que para el uso normal) , y desde hace 3 dias tengo problemas en la notebook con mi placa intel, parece que surgió un problema y pusieron mi placa de video en el blacklist de compiz, lo que no permite tener los efectos de escritorio.

En la pc de escritorio intenté instalarla con el gestor de controladores restringidos, me detecta la placa de video, me recomiendo un controlador, pero no lo descarga, se queda en 0% y no avanza, me quedé esperando como 10 minutos y viendo la actividad de red no aumentaba, me decidí a cancelar y a intentar de la misma forma que lo hice en ubuntu  8.04, utilizando envy.

Instalando el driver para nvidia en ubuntu 9.04con Envy

A mi me resultó muy facil la instalación, aquí los pasos:

  1. ejecutar en una consola sudo apt-get install envyng-qt son unos cuantos MB pero no importa :-).
  2. luego que temina la instalación ejecutar sudo envyng para abrir la interfaz gráfica. (gracias sergioberton por la corrección)
  3. Debería aparecer esta ventana que muestro a continuación,  lo mas recomendado es seleccionar lo que recomienda el programa, a mi me funcionó sin problemas, luego de darle click a aplicar, descarga el  controlador (imagen 2) y pide reiniciar, luego de reiniciar el driver está instalado y funcionando.

envyng1

envyng2

Espero que la info sirva, si agkuien tiene algun problema, deje un comentario y ayudaremos en lo posible a solucionarlo.

Tags: , , ,

Busquedas Relacionadas
  1. 37 Comentarios en “Instalar el driver nvidia en Ubuntu 9.04”

  2. En realidad envyng -t es para la interfaz texto, por consola.

    Yo tengo diversos errores al ejecutar Envy, aparentemente con Qt, supongo que debe ser poque esta versión lleva Qt 4.5, no estoy seguro.

    Tampoco me funciona la versión GTK.

    Sigo buscando, sino voy a por la descarga del CD y a instalar de cero. :'(

    Saludos y Gracias por la data!

  3. Interesante, yo tengo problemas pero en Debian 5 con una Geforce 9800. Realmente le tengo que dedicar tiempo para ver si compilo el driver o si busco un repositorio con un binario.

  4. Julio, probá con envy, tendría que funcionar sin problemas en debian 5, yo no lo he probado , lo voy a hacer en estos dias que tengo que instalar debian 5 en casa, si querés aguantame que pruebo y me escribo otro post 🙂 , saludos.

  5. Por dan el dia 30 de April de 2009 | Responder

    Tengo una compaq CQ50 103LA con Proc AMD Athlon X2 64, instale el sistema y todo ok, termino el procedimiento de instalación de la tarjeta de video (Nvidia GeForce 8200M), reinicio y no arranca el sistema gráfico para nada, prové con la versión i386 y amd64 del Jaunty, y el mismo problema…., alguna sugerencia??, gracias.

  6. Hola dan, probá instalando una version que no sea la que te recomienda el envy, elegí una mas vieja a ver que pasa.

    Saludos.

  7. Por problema el dia 1 de May de 2009 | Responder

    Yo tengo un problema, al hacer todos estos pasos y finalmente darle a “aplicar” me sale este mensaje.. “EnvyNG has detected that the headers for your kernel are missing and cannot be installed”. Y no sé solucionarlo :S

  8. Por Marcelo el dia 1 de May de 2009 | Responder

    Hola, he probado tu procedimiento y funciona correctamente.
    Muchas Gracias

  9. Por jorge luis el dia 4 de May de 2009 | Responder

    tambien tengo el compaq cq50-103la y con esta version 9.04 como que no va. no entiendo por que ni envi ni los controladores restringidos no incluyen el driver 177.82 que es el único que le funcionaba a la nvidia gforce 8200. solo por eso me toco devolverme a la 8.10

  10. JorgeLuis, no has probado con el 173? ese debería funcionar con tu placa… no siempre es necesario utilizar la que recomienda envy..

    prueba y dime como te ha ido.

  11. Por Arejuko el dia 6 de May de 2009 | Responder

    lo he intentado de varias maneras y no lo he conseguido se queda en 75% espero y nada, y anteriormente ya lo habia instalado lo que paso que formatie de nuevo y ahora no quiere instalarse

  12. Por Mario el dia 10 de May de 2009 | Responder

    Pues les comunico que desgraciadamente el Envyng ya no funciona, no se porqué razón. Sin embargo logré instalar el driver de Nvidia y hacerlo correr simplemente haciendo Sistema-Administración-Controladores de Hardware.
    Pero para mi sorpresa, para mi tarjeta gráfica, con la que toda la vida me funcionaba de pelos el Compiz-Fusion en versiones anteriores de Ubuntu, ya en Jaunty no funciona.
    Lástima…

  13. Hola mario, como es eso de que el envy no funciona? , no anda mas para nadie? , el envy se lo usa cuando no queda otra forma de instalar el controlado, o cuando el gestor de controladores restringidos no detecta la placa de video.
    Decime que pala de video tenés y vemos que se puede hacer.

    Saludos.

  14. Por Mario el dia 16 de May de 2009 | Responder

    Gracias elteto, un saludo muy afectuoso. Si, resulta que hice el upgrade de Ubuntu 8.10 al 9.04 y para mi sorpresa me quedé sin efectos de escritorio, según entiendo son varias las tarjetas gráficas que están teniendo problemas.
    La mía es una Geforce MX 4000, de 128, viejita viejita pero el Compiz le corría sin ningún problema en las distribuciones anteriores.
    Yo ya tenía instalado el Envyng pero cual fue mi sorpresa de que no abre la interfaz gráfica, y la textual se cuelga. Intenté desinstalarlo y volverlo a instalar pero con idéntico resultado.
    Ya tengo varios días de trastear con esto, si pudieras sugerirme algo te agradecería.

  15. Por luis el dia 18 de May de 2009 | Responder

    cuando intalo estos drivers y reinicio me sale la parntalla de carga y luego se me queda negra totalmente.
    que puedo hacer.

  16. Por Tomás el dia 20 de May de 2009 | Responder

    Muy bueno y útil tu post. ¡Gracias!

    Saludos.

  17. Por Roberto el dia 22 de May de 2009 | Responder

    hola, te queria hacer una consulta, segui los pasos del tutorial y efectivamente me instalo el driver, peeeeeroooo cuando vuelvo a iniciar ubuntu me vuelve la resolucion a 800×600 y tengo que hacer el paso de envy nuevamente.
    ¿Como hago para que quede definitivo?

    DEsde ya muchas gracias.. muy bueno el tuto.. bien explicado.

    Saludos !

  18. deberías ir al menú Sistema/Preferencias/Pantalla , en mi caso que tengo una nvidia 6600, me dice que no puedo usar la aplicación que trae ubuntu para configurar la resolución, que debo usar la que trae el driver, y me consulta si la quiero abrir, le digo que sí y me abre el panel de control Nvidia, de ahí configuro la resolución y listo.

    espero que te sirva, cualquier cosa preguntá.

    saludos.

  19. Por Francisco el dia 29 de May de 2009 | Responder

    Hola,

    A mi me pasa que no puedo aumentar la resolución a más de 800×600.

    Cuando pongo sudo envyng -g, se queda en la ventana que dice Downloading Package, pero se queda en 0% y no avanza (y eso que dejé la mqna funcionando por mucho tiempo)

    Que puedo hacer

  20. compre una nvidia segun el cd de drivers dice que es 178.53 cuando instale ubuntu 9.04 me sale el dirver 180 o 173 instalo el 180 y no puedo y se ve mal con una resolucion de 1280 solo puedo usarla en 1024 alquien sabe que hacer…
    saludos

  21. Por Rodrigo el dia 26 de June de 2009 | Responder

    Hola, Tengo un pentiun 4 , anteriormente tenia el ubuntu 8.04 y funcionaba sin problemas, pero descarge la ultima version 9.04 y se me cuelga la maquina, segun lo que veo son los controladores de video, como puedo saber que nvidia tiene mi placa, es un pc chips P – 25 G Ver. 3.0 y como puedo solucionar mi problema, saludos

  22. Por Fabian el dia 15 de July de 2009 | Responder

    Gracias soy nuevo en ubuntu y me sirvio. mi placa es NVIDIA Geforce 8600 gt.
    PD: el comando para la consola es “sudo envyng -k” sin comillaas. Al menos a mi me funciono asi. Saludos!!

  23. Por macz el dia 19 de July de 2009 | Responder

    Muchas gracias amigo, realmente funciono por el lado de envyng, trate de muchas maneras y nada, realmente agradecido.
    saludos

  24. Por caminante_x el dia 22 de July de 2009 | Responder

    Aqui para los que no le reconocio por completo a pesar de descargara los controladores una solucion que a mi me ayudo

    no se aceptan enlaces a articulos de ese sitio si en el artículo no han citado la fuente.

  25. tengo problema con los efecto visuales cuando lo activo me dice que no encuentra los controladores pero esta instalado y no se porque ayudemen por favor gracias

  26. Hombre, gracias!!!!
    he usado por mas de medio año Ubuntu, con el me inicie en Linux xD
    luego estube con Fedora, y no habia tenido problemas,
    hasta la semana pasada que decidi instalar Fedora 11 Leonidas y su Ext4 😛

    pero el problema del driver de mi gráfica!!!
    he sufrido
    asi que decidi volver a instalar Ubuntu 8.10
    el ultimo cd que pedí T_T

    y gracias a este post pude activar mi gráfica una NVIDIA GeForce4 mx 4000

    gracias !!!
    no sabia de esta aplicación
    lo que dura este mes de agosto usaré Ubuntu luego volveré a probar Fedora 11 y tratare de instalar EnvyNG para ver si logro instalar el driver!!
    otra vez gracias!!!

  27. Gracias!!
    excelente post!!

  28. Por javiz el dia 23 de August de 2009 | Responder

    Hola chicos, bueno les dire que hace poco me entre en esto de software libre…

    Tengo instalado ubuntu 9.04 y una tatjeta grafica nvidia 8400gs, lo que hice para activar 3d fue tan simple como:

    ir al escritorio, click derecho en algùn espacio vacìo, cambiar fondo de escritorio, te vas a la pestaña efectos visuales y cuando quise seleccionar “extra” me pidio instalar el driver privativo y demases puse descargar e instalar luego espere un momento… descargò, instalò y reinicie el equipo

    luego hice lo que estaba anotado mas arribita para comprobar la aceleracion de hardware, anotè en terminal: glxinfo | grep rendering y…
    listo… direct rendering: yes …pude activar extra en efectos visuales 😀

    PERO…. antes que nada instale todas las actualizaciones del sistema, porque antes de instalarlas habia hecho lo mismo que describì anteriormente (lo de ir a escritorio…) y no me salio nada acerca de descargar en instalar software privativo etc… entonces saquè la conclusiòn de que alguna actualizacion del sistema (no se cual, porque instalè todas D:) me permitio activar de esta forma mi nvidia 8400gs.

    espero haberles servido de ayuda, pues ese fue mi metodo 😉

  29. Gracias javiz por tu aporte 🙂 .

    saludos.

  30. Por Xavier Rojas el dia 26 de August de 2009 | Responder

    buenas noches, hace 2 semanas e estado probando este nuevo sistema operativo (siempre había usado windows), todo bien ahsta los momentos… pero tengo problemas con mi driver de video, mi targeta de video es una nidia gforce mx4000, y no me descarga los drivers. que puedo hacer? porfavor que alguien se apiade de ESTE NOVATO!!!!!!!!!!!!!! Espero sus respuestas, y porfavor los mas explicitas posibles pues no conozco muy este sistema. saludos desde Venzuela.

  31. Algo parecido para fedora?
    no puedo instalar mi grafica es la misma de Xavier Rojas
    nidia gforce mx4000
    ayudame por favor!!

  32. Por Gatillo el dia 7 de September de 2009 | Responder

    SOCORRO!!
    Hola, me compré una COMPAQ PRESARIO CQ 60: La compu es esta:
    http://www.bestbuy.com/site/olspage.jsp?skuId=9454253&type=product&id=1218106990994

    Ni bien llegó le instalé Ubuntu, pero nunca pude hacer funcionar su NVIDIA, la pantalla me aparece dividida en 6 partes, y en cada una hay un “minimonitor” de resolucion 640×480 por lo poco que se ve.
    Usé el siguiente comando porque me dijeron que puede ser de utilidad:

    gatillo@gatillo-laptop:~$ lspci | grep -i nvidia
    00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
    00:01.0 ISA bridge: nVidia Corporation Device 075e (rev a2)
    00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
    00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
    00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
    00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
    00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
    00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
    00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
    00:06.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] IDE (rev a1)
    00:07.0 Audio device: nVidia Corporation MCP78S [GeForce 8200] High Definition Audio (rev a1)
    00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
    00:09.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
    00:0a.0 Ethernet controller: nVidia Corporation MCP78S [GeForce 8200] Ethernet (rev a2)
    00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
    00:14.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
    02:00.0 VGA compatible controller: nVidia Corporation GeForce 8200M G (rev a2)
    Podrían ayudarme? Creo que el xorg.conf habrá quedado mal configurado y esto es lo que ocasiona el problema. Por lo que se veía en las pantallitas había aceleración 3d (al menos los efectos del compiz).
    Si bien mi monitor es
    15.6″ high-definition HP LED-backlit WXGA display
    With BrightView technology supports high-definition video playback with 1366 x 768 resolution for movies and games with stunning clarity.
    Ahora está funcionando en 1280×720.
    Muchas gracias por la ayuda!

  33. Por Gatillo el dia 9 de September de 2009 | Responder

    SOLUCIONADO!!
    Gracias a todos! la solución la encontré con la ayuda del foro de Kubuntu:
    http://www.kubuntu-es.org/foro/200909/problemas-nvidia-laptop-compaq-cq-60?page=2

  34. Por aaron el dia 1 de March de 2010 | Responder

    soy totalmente nuevo en esto y no se que hacer tengo una computadora de la prehistoria, pero si corre aceptablemente windows XP no entiendo por que ubuntu NO, pues me han dicho que necesita menos recursos que XP, mi problema es que los graficos se ven muy mal en ubuntu, tengo una computadora compaq con una tarjeta grafica nvidia vanta ltd de 8M, no se si se pueda hacer algo con este vejestorio?, garcias

  35. Por aaron el dia 1 de March de 2010 | Responder

    jajaja curiosamente hize una tonteria al hacer lo que decian aqui arriba y escoger una que no funciono ni de broma si no por el contrario me marco error al inicio y me bajo el tamaño de la resolucion pero curiosamente me mejoro la nitidez de las cosas jajjaja estoy muy perdido

  1. Trackback(s)

  2. 25 de April de 2009: Instalar driver nvidia en ubuntu Intrepid Ibex - e-abaco
  3. 25 de April de 2009: Instalar driver nvidia ubuntu 8.04 Hardy Heron - e-abaco
  4. 25 de April de 2009: Bitacoras.com

Hacé un comentario en el post, participá!!!